Synchronization Issues with German Handelsregister (DE.RC)

Incident Report for CDQ Cloud Services

Identified

We have identified the root cause in our synchronization functionality. A fix is being prepared, and we will fully backfill the data gap once it is deployed.

No action is required on your side. All previously synchronized data remains available.
Posted Aug 19, 2026 - 14:57 CEST

Investigating

We are currently experiencing delays in the synchronization of data from the German commercial register (Handelsregister, source ID DE.RC).

What this means for you: Business partner records sourced from DE.RC may not reflect register changes. This affects Lookups and Change Notifications for German legal entities.

Our team is investigating the root cause.
Posted Aug 19, 2026 - 14:57 CEST
This incident affects: CDQ Cloud Services (Referencedata API).