Cloud Apps: Data Sources Unavailable
Incident Report for CDQ Cloud Services
Resolved
We have identified the root cause of the issue affecting Cloud Apps.

The problem stemmed from a framework upgrade applied to our backend API to ensure the latest security patches. This upgrade changed how trailing slash matching is handled, causing requests with unnecessary trailing slashes to fail. We have reconfigured our backend to prevent this new behavior and ensure consistent request handling.

The issue is now resolved, and all services are functioning as expected. Thank you for your patience and understanding. Please reach out to our support team if you experience any further issues.
Posted Nov 26, 2024 - 11:20 CET
Monitoring
A fix has been implemented for the issue affecting Cloud Apps, where data sources could not be fetched due to a 500 - Internal Server Error. The issue is now resolved, and we are closely monitoring the situation to ensure stability.

Thank you for your patience, and we will provide a final update once the issue is fully confirmed as resolved
Posted Nov 25, 2024 - 20:12 CET
Investigating
We are currently investigating an issue affecting Cloud Apps, where data sources could not be fetched due to a 500 - Internal Server Error. Please note that APIs are not impacted and remain fully operational.

Our team is actively working to identify and resolve the issue. We appreciate your patience and will provide updates as soon as more information becomes available.
Posted Nov 25, 2024 - 18:07 CET
This incident affected: CDQ Cloud Services (Cloud Apps).