Between August 7, 2025, 18:00 CET and August 8, 2025, 14:00 CET, some customers experienced timeouts when performing lookups, which also affected request handling and curation responses. In addition, monitoring results may not have been available.
The issue has been resolved, and services are now operating normally.
Posted Aug 18, 2025 - 14:27 CEST
Update
We are continuing to monitor for any further issues.
Posted Aug 11, 2025 - 10:53 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 08, 2025 - 15:20 CEST
Investigating
We are currently investigating the issues.
Posted Aug 08, 2025 - 09:26 CEST
This incident affected: CDQ Cloud Services (Bankaccount Data API, Data Compliance API, Data Validation API, Referencedata API, Data Curation API, Data Exchange API).