Performance degradation of the Business Partner Lookup

Incident Report for CDQ Cloud Services

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2026 - 08:16 CEST

Investigating

We are experience performance degradation of the Business Partner Lookup functionality. We are working on fixing the issue.
Posted Apr 24, 2026 - 15:51 CEST
This incident affects: CDQ Cloud Services (Referencedata API).