Google Places Data Source in Lookup

Incident Report for CDQ Cloud Services

Resolved

The issue affecting the Google Places data source in the Lookup service has been successfully resolved.

The service is fully operational again, and all systems are functioning as expected.
Posted Oct 17, 2025 - 11:47 CEST

Monitoring

A fix has been implemented, and the Google Places data source in the Lookup service is now operational.

We are currently monitoring the system to ensure full stability and performance.
Posted Oct 17, 2025 - 08:28 CEST

Investigating

We have identified and confirmed an issue affecting the Google Places data source in the Lookup service.

Our team is currently analyzing the root cause and working on a resolution.
Posted Oct 16, 2025 - 19:53 CEST
This incident affected: CDQ Cloud Services (Referencedata API).