Performance degradation of the Business Partner Lookup

Incident Report for CDQ Cloud Services

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2025 - 09:49 CET

Investigating

We are experience performance degradation of the Business Partner Lookup.

Our team is investigating the issue.
Posted Nov 12, 2025 - 12:07 CET
This incident affects: CDQ Cloud Services (Referencedata API).