A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2026 - 09:03 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 12, 2026 - 10:00 CEST
Investigating
We are currently experiencing performance degradation across part of our services, which may cause delays when adding or updating data. Consequently, search results may temporarily not reflect the most up-to-date information.
Posted Aug 11, 2026 - 12:00 CEST
This incident affected: CDQ Cloud Services (Referencedata API, Data Exchange API).